macd超短线参数设置

MACD指标参数如何设置?

MACD指标

MACD称为指数平滑移动平均线,是从双指数移动平均线发展而来的,由快的指数移动平均线(EMA12)减去慢的指数移动平均线(EMA26)得到快线DIF,再用2×(快线DIF-DIF的9日加权移动均线DEA)得到MACD柱。MACD的意义和双移动平均线基本相同,即由快、慢均线的离散、聚合表征当前的多空状态和股价可能的发展变化趋势,但阅读起来更方便。当MACD从负数转向正数,是买的信号。当MACD从正数转向负数,是卖的信号。当MACD以大角度变化,表示快的移动平均线和慢的移动平均线的差距非常迅速的拉开,代表了一个市场大趋势的转变。

MACD指标参数设置

1

我们首先要了解macd的计算公式

DIFF =EMA(CLOSE,12) - EMA(CLOSE,26);

DEA  =EMA(DIFF,9);

MACD = 2*(DIFF-DEA);

从上面可以看出 ,首先计算12日移动平均线,26日移动平均线,得到DIFF,然后计算DIFF的9日移动平均线DEA,然后(DIFF-DEA)*2,求得MACD,也就是说能设置的参数有12,26 和 9 日 这三个数的组合 。

2

打开软件上的股票行情软件,以同花顺为例(这不是做广告啊,举例),进入到上证指数的K线图中。

3

点击K线设置按钮,进入K线设置界面。

4

找到MACD这个选项,点击旁边设置按钮。

5

这个时候界面上就提供了短期天数和长期天数,以及M的输入,修改完毕之后,系统会自动完成保存,点击左上角的返回按钮就可以了。

6

修改macd默认参数的注意事项,短期天数由12变大,将macd对价格敏感度将变慢,金叉和死叉将会延后。短期天数由12变小,那么macd对价格敏感变大,金叉和死叉很快出现。长期天数26和M的变化也是如此.在实际操作中,需要自己根据自身情况进行设置。

用MACD做短线如何设置指标?

MACD
是属于均线函数系统。你记住今天的MACD的数值参数,半个月后再看今天MACD的数值就会发现数值在变化。因为MACD存在骗线,需要妥善运用。只能作为暂时性参考,实际意义全无。个人意见,仅供参考。

超短线指标参数设置(MACD)

外汇风险太大。不做超短线也不行,这些参数要你自己去摸索了,这和你的操作习惯,操作理念有关

·求MACD和KDJ指标在超短线中的作用?数值怎样设定

MACD 不灵
KDJ 低位金叉买入信号KD交叉白线穿越黄线.数值越底保险系数越大.

通达信MACD公式,请高手请把下面指标公式里的金叉死叉+个箭头表示谢谢

DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIFF,9);
MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
STICKLINE(低位金叉,0,0.08,6,0),COLORYELLOW;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,0.06,6,0),COLORFF00FF;
DRAWICON(二次金叉,DEA*0.9,1) ;
DRAWTEXT(二次金叉,0.1,' 二次金叉'),COLORYELLOW;
DRAWICON(CROSS(DIFF,DEA),DEA*1.02,1);
DRAWICON(CROSS(DEA,DIFF),DIFF*0.98,2);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA) AND DIFF<0;
STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;
底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK4;
DRAWTEXT(底背离,DIFF,' 底背离'),COLORFF00FF;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK4;

请求高手把这个【精准买卖】指标公式改为条件选股公式,成功率蛮高的,而且无未来函数。(能改进更好)

这个就是简单地MACD选股啊,中间那几个划线一删就是了:
DIFF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=(DIFF-DEA)*2;
买入:CROSS(DIFF,DEA);
卖出:CROSS(DEA,DIFF);